Jump to content



Photo

Z3 BOOTLOOP


  • Please log in to reply
4 replies to this topic

#1 OFFLINE   AmineHL

AmineHL

    Freshly registered FAQ reader

  • User
  • 3 posts
    • Time Online: 24m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 22 November 2019 - 14:50

Hello there. I own a Z3 model D6603. It is unlocked bootloader and Before it had got the bootloop i had Lineage OS 16 custom rom installed on it (Android 9). I was watching some videos on chrome and then the phone heated a little and then restarted. I thouhgt it was maybe some sort of instability but then it started just bootlooping.
Current Status right now is :
Once connected to pc goes to flash mode.
I can get it to fastboot.
When connected to charger just goes into endless bootloop where only SONY logo appears and then quickly restarts
In attempt to fix it I flashed stock FTF using multiple versions of Flashtool which was fruitless. I also Tried with EMMA but nothing helped still. And then after looking I think it might be damaged TA and I've seen so many say that if that's the case then the phone is bricked forever unless you have had a backup from a previous working state which I actually do. The problem is that I don't know how to flash this TA back since the phone doesn't boot to restore it through ADB. I saw that S1tool works with older devices and doesn't work with Z3 models so I wonder if there is a way to fix this. Thank you for your time.
PS : My power button doesn't work I used to use fastboot to boot it when necessary
that's the TA backup I have I hope it helps anyhow

Attached Files


Edited by AmineHL, 22 November 2019 - 14:53.

  • 0

#2 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 12015 posts
    • Time Online: 560d 12h 15m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 22 November 2019 - 16:53

 

The problem is that I don't know how to flash this TA back since the phone doesn't boot to restore it through ADB.

 

Good for you. Playing with trim area in the case when you have no idea what you are doing will kill your phone for sure ;)

 

 

And then after looking I think it might be damaged TA

 

Why do you think that? Phone with damaged trim area will never power up. Never.

 

I have no idea what you did to your phone, but for start you can try hard reset. If that will not help, most likely you have to try to flash it via recovery and follow tutorials you've used step by step.


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...

#3 OFFLINE   AmineHL

AmineHL

    Freshly registered FAQ reader

  • User
  • 3 posts
    • Time Online: 24m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 22 November 2019 - 17:19

Hello Jurij and thank you for the time you u had to reading my post. Why I think it might've been the TA partition is that I just thought looking at others phones with close symptoms and people in posts said it might be just the TA partition damaged. Well I hope it isn't but anyways the problem is that I can't access recovery with any way the phone just boots up but i can't get into recovery the sony logo appears for very few seconds much less than the usual and dissapears with no led then if it is connected to usb it just takes me to flashmode if not it just keep restarting. Flashing through flashtool working fully no errors at all then phone just do this and nothing changes
  • 0

#4 OFFLINE   AmineHL

AmineHL

    Freshly registered FAQ reader

  • User
  • 3 posts
    • Time Online: 24m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 24 November 2019 - 22:52

The rebooting loop looks like this vid :
is the solution presented in this video valid ?
  • 0

#5 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 12015 posts
    • Time Online: 560d 12h 15m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 25 November 2019 - 10:36

 

Why I think it might've been the TA partition is that I just thought looking at others phones with close symptoms and people in posts said it might be just the TA partition damaged.

 

You can't damgae Trim Area partition by just using phone.

 

 

The rebooting loop looks like this vid :
is the solution presented in this video valid ?

 

It might be. The problem is i don't trust custom firmwares at all, and you've had one:

 

 

it had got the bootloop i had Lineage OS 16 custom rom installed on it (Android 9)

 

If that OS was working good, then we can assume hardware problem of your device. Bootloop usually happens because of two reasons:

 

1. You was flashing your phone and you've did something wrong. In many custom firmwares you must clean cache, dalvik etc. and if you will forget to do that, phone stucks in boot loop. But that's not your case, as you were just watching youtube.

 

2. The second reason is hardware problem... Usually it's problem with ram / flash ic which needs to be rehot / reballed or replaced.

 

My advice is to visit good service centre, ask them to take a look on your phone, rehot / reball ram in your device, maybe that will help. They should know what to do :) Good luck, and let us know if that helped :)


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...


0 user(s) are reading this topic