Jump to content


Meet Sony Xperia XZ Premium:


Photo

Sony Xperia Z1 C6903 software problem dead handset


  • Please log in to reply
13 replies to this topic

#1 OFFLINE   clx

clx

    Freshly registered FAQ reader

  • User
  • 7 posts
    • Time Online: 4h 58m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Other

Posted 04 September 2015 - 15:06

Hello. 
First off, thanks for the most complete tutorial on this problem. I read all the 52 pages (at this very moment) on the XDA thread regarding this same problem but did not find it very easy to follow: 

Please Login or Register to see this Hidden Content

Your one, is more straight to the point and nonetheless does not omit a thing.
 
Have a Sony Z1 (6903) for 1,5 yrs now. NEVER root-ed by me at least.
Around two months ago made a gap to Lollipop through phone's system update (I think it was 5.0.2 or 14.5.A.0.270 but could be mistaking and it was 14.5.A.0.242 - both Italian). 
 
Q1: the problem with the people listening my robotized voice definitely happened, which version was it or in which version of Sony's Lollipop was it solved?
 
Around 10 days ago the Z1 has become to say that apps are closing unexpectedly. The phone at some point asked me whether I'd like to install a new version (of something, maybe firmware I was sleepy). I said NO. In the morning it was still functioning. Some apps closed again unexpectedly but nos as many as previous evening. Then in 5 minutes, all the sudden, I see the screen of the phone is black lighted and wasn't reacting to anything, not even disconnect button. I did hard reset by pushing the red little button in the SIM slot. It vibrated 3 times and disconnected itself.
 
From that time is unresponsive. Can't power on; no LCD or LED reaction for power button or charger; no reaction to connection to PC (unknown device); PC cannot detect the phone with Vol -or Vol +; phone doesn't vibrate when holding Vol+ and Power together.
Flashtool says that I connected a phone with USB debugging OFF. 
 
S1 Tool does see the it in the Emergency mode (SEMC Flash device does installs fine).
But gives the following error:
 
DETACH USB CABLE FROM PHONE
REMOVE BATTERY FROM PHONE
ATTACH TESTPOINT
PRESS "READY", THEN ATTACH USB CABLE TO PHONE
will use Sahara protocol ... 
REMOVE TESTPOINT NOW, THEN PRESS "READY"
PROCESSING ...
SERIAL NUMBER : CFCEFF01
HARDWARE ID : 04000100E1007B00
PRODUCT DETECTED: "MSM8974 OEM1 fused"
HASH :49109A8016C239CD8F76540FE4D5138C87B2297E49C6B30EC31852330BDDB177
Emergency loader uploaded ...
RUNNING S1_PRELOADER VER "LOADER_RELEASE_MSM8974_23_4_AID_4"
LOADER AID: 0004
can't get S1 command header
LOADER NOT RESPONDING
 
I DID use till now the bootloader (APPSW) that you provided for the 6903: 14_2_A_0_290.APP_SW_Honami_GENERIC_1272_6084_S1_SW_LIVE_6732_PID1_0005_MMC.SIN_FILE_SET
Same result as above...
 
Few days ago I did what you described above in this thread: made my own APPSW.SIN_FILE_SET based on the newer official firmware version 14.5.A.0.270.
The phone VIBRATED as it was (trying) to connect ON. Even S1 Tool acted a bit different - did not give the S1 command header (at least for now).
I got the phone up to see whether it had some movement on the screen but it was OF already and the error came back in S1 Tool:
can't get S1 command header
LOADER NOT RESPONDING
 
 
ATTENTION: my APPSW DID NOT INCLUDE THE "boot.zip". I only did what you taught us, above. My .sin_file_set did not also include the two .XML files that the .sin_file_set archive (which it is after all): update.xml  & boot_delivery.xml.
I learnt their existence in the 14.2.A.0.290 bootloader of yours only later, out of curiosity.
 
Q2: do you think S1 tool could accept only "newer" firmware versions ? Why it vibrated only at that time..
Q3: if so, then probably the phone didn't start because MY sin_file_set didn't have  the boot.zip archive and the two .XML files to "tell" the phone to flash them the boot loader too?
 
 
Next day I created my other  APPSW.SIN_FILE_SET.  This time with the above mentioned boot.zip and the .XML files (took them from the Bundler that Flashtool created after downloading the version, very comfy by the way, no need to un-archive the firmware' .FTF).
 
Unfortunately - same result as above.
 
Q4: does it want now a NEWER version of APPSW.SIN_FILE_SET ? or it doesn't matter of kind of bootloader are we giving to it (even if the currently installed is higher, I mean)
 
Q5. if positive, the APPSW of which Z1 firmware version should I make and flash it to the phone? (which current official firmware is newer?)
 
Q6: maybe I should give other type of files to rewrite the boot loader section, for instance the ACPU" which contain boot.sin (only)?
 
Q7: when it tried to boot, what is the reaction of the phone when S1 Tool actually works (after the "LOADER AID: ...." message I intend? It boots and then flashes its stuff onto the phone or everything goes silent (without booting/ON)? 
 
 
MY SEARCHES on the net on this error (very few!). 
I found these following suggestions in such situations:
 
1. install latest usbflash drivers - 3.0.0.7 installed, latest

use different usb cable  - I used another, and shortest too
use different usb port  - did that, switched PC's also, tried on Win XP too (besides my Win7 Ultimate)
use external usb hub - did NOT try that
switch usb mode in BIOS of your PC to HIGH SPEED, NOT "FULL SPEED"  - don't have this option

 
2. the

Please Login or Register to see this Hidden Content

 , there's a Dutch person (herogjan) with same problem (page 17), and he eventually gave up, tried a few things.
 
The_laser , the writer of S1 tool, answered to the Dutch:
"main loader not responding, this is abnormal for your situation.
you doing testpoint job with or without battery ? try to connect battery, when s1tool ask you to remove testpoint and try to change usb port."
 
I tried to connect battery: A. from the very beginning (gives an error about device)  B. connected the battery before releasing the TestPoint and clicking the S1tool button the 2nd time)..
Same result:  can't get S1 command header
 
3. "install usbflash drivers from s1tool package,do not use usb 3.0 port, use short usb cable."
I used same those ones (even formatted and started from zero). Did not use usb 3.0 (although tried). Used short cable too as I mentioned.
 
4. The_laser suggests that if in such situation you don't have trim backup - you're toast and should give it out for spare parts..
 
Q8: is it so? I repeat, I didn't do ANY root or Flashtool updates. Maybe, I interrupted one, true. although I don't understand how it did downloaded in the first place, I had very low speed Internet at that time and it would've taken an eternity to download it.
 
5. You write above: 
"5. Set up compatibility with Windows XP SP3 to avoid problems on windows Vista or newer." 
 
Q9: what do you mean exactly and how to do it?
 
6. Some other person on the same XDA thread says:
"i used testpoint while holding volume down key and it worked, before it did not work by testpoint only"
 
Q10. Unfortunately he didn't mention what he did exactly, his steps. Didn't remodel this. Any advice?
 
7. Other

Please Login or Register to see this Hidden Content

 "they've flashed the boot loader and then it started so they've then flashed the firmware and it works"
Q11. I should be able to flash the boot loader. Where from and which one should I take?
 
Q12: Medusa box, would be of help? How much does it cost?
 
Q13: Setool 3, expensive, would it help? What other things does it do. I might need it for my phone shop.
 
Q14: you mentioned above: "1. Make sure, that you have fully charged battery. 50% is absolute minimum."
I just thought, maybe it is TRYING to boot and to flash.. but the battery is not full enough. How can I measure it.. maybe it is NOT CHARGING at all from the wall charger.
 
Would appreciate any of your help. Thanks in advance the moderator and the users.

Edited by clx, 04 September 2015 - 15:09.

  • 0

#2 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 11887 posts
    • Time Online: 550d 20h 22m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 04 September 2015 - 16:00

Hello,

 

I've moved your post to a new topic in correct forum. There is a lot of questions, i will try to answer to them one by one, but for each question you should create new topic. 

 

 

First at all:

 

 

Have a Sony Z1 (6903) for 1,5 yrs now. NEVER root-ed by me at least
From that time is unresponsive. Can't power on; no LCD or LED reaction for power button or charger; no reaction to connection to PC (unknown device); PC cannot detect the phone with Vol -or Vol +; phone doesn't vibrate when holding Vol+ and Power together.

 

That phone should be on warranty. Why didn't you send your phone to Sony service centre to get a new phone?

 

 

 

Q1: the problem with the people listening my robotized voice definitely happened, which version was it or in which version of Sony's Lollipop was it solved?

 

I don't know, try different firmware versions, if lollipop is too buggy, use Kit Kat firmware or Jelly Bean firmware.

 

 

I DID use till now the bootloader (APPSW) that you provided

 

APPSW is not a bootloader, it's the main part of firmware. It should contain boot files as well in case of C6903 phone.

 

 

Q2: do you think S1 tool could accept only "newer" firmware versions ? Why it vibrated only at that time..

 

S1Tool can flash any stock C6903 firmware version to any C6903 phone in .sin_file_set or .zip format.

 

 

Q3: if so, then probably the phone didn't start because MY sin_file_set didn't have  the boot.zip archive and the two .XML files to "tell" the phone to flash them the boot loader too?

 

I have no idea what did you messed up with your appsw file.

 

 

The rest of your questions is pure nonsense.

 

The main guestion is - how your phone is now detected in device manager when you hold volume down button and attach usb cable?


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...

#3 OFFLINE   clx

clx

    Freshly registered FAQ reader

  • User
  • 7 posts
    • Time Online: 4h 58m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Other

Posted 04 September 2015 - 22:13

Device manager sees it as HID-compliant device.
Is it good or bad..


  • 0

#4 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 11887 posts
    • Time Online: 550d 20h 22m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 04 September 2015 - 22:43

Bad. It should be detected as SOMC flash device, QHUSB or something like that or when boot is damaged - ZEUS flash device. Your phone is disassemblied now?


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...

#5 OFFLINE   clx

clx

    Freshly registered FAQ reader

  • User
  • 7 posts
    • Time Online: 4h 58m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Other

Posted 05 September 2015 - 08:26

It is detected as SOMC or SEMC flash device (on diff. PCs) only after I connect it with the TestPoint connected.
Yes, the back cover is off.


  • 0

#6 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 11887 posts
    • Time Online: 550d 20h 22m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 05 September 2015 - 12:48

But i'm asking how it's detected when you hold vol- and attach usb cable...

 

 

If it's not detected - try deep hw reset - make sure that battery is connected and hold that button:

 

Z1 HW Reset.jpg

 

for at least 120 seconds. Then hold vol- button and attach usb cable. Let me know what device shows up.


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...

#7 OFFLINE   clx

clx

    Freshly registered FAQ reader

  • User
  • 7 posts
    • Time Online: 4h 58m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Other

Posted 05 September 2015 - 20:18

Good evening. Tried what you suggested, two times, yet same result: HID-compliant device.

Both with "Vol DOWN" or without it it sees the phone as HID-compliant device (previously wasn't recognizing the phone just by connecting the data cable).

Please let me know how should've reacted.

How to test if the battery's OK and charging or charged? On a thread I saw someone that because of some new FW release the phone'battery is seen differently (fully charged under a certain FW and only 30% charged under another).

Other suggestions?


Edited by clx, 05 September 2015 - 20:19.

  • 0

#8 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 11887 posts
    • Time Online: 550d 20h 22m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 05 September 2015 - 22:06

Well, in this case the only thing you can try - flash your phone with all firmware parts:

 

1. APPSW,

 

2. FSP,

 

3. ELABEL

 

using current S1Tool: Attached File  s1tool 28II2015.exe   3.13MB   4207 downloads and S1 EMERGENCY MODE (testpoint method). If that will not help or flash will fail, it's hardware problem. And i bet it's hardware problem, because phone behaviour was highly abnormal. Too bad you did not send your phone to Sony for warranty repair...


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...

#9 OFFLINE   clx

clx

    Freshly registered FAQ reader

  • User
  • 7 posts
    • Time Online: 4h 58m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Other

Posted 05 September 2015 - 22:14

BTW, I found on

Please Login or Register to see this Hidden Content

 

For everybody who is asking about a hard bricked Z1S :

I revived a completely dead Z1S using this guide. The phone had no flashboot, fastboot, no blinking led, no nothing.
First, I use the s1 flashtool with the C6903 package, that allowed me to enable the charging mode in the phone. Then I charged it to 100%.
Then, I used the Flashtool (Sony mobile flasher by Androxyde) with XperiFirm to flash the .137 firmware.

Then I rebooted the phone and it worked !!!!

 

How did he charge the battery using the emergency mode (or flash mode..he wrote he use the flashtool)?
Because I suspect the error I get is because the battery isn't fully charged (or at least 50% charged as you write in your other post before using s1tool).

That also explains how come I was able ONCE to listen the phone vibrating..the battery somehow charged a bit (after multiple attempts I probably left it in the emergency mode, connected) so it found some resources to try and boot the phone..
 


  • 0

#10 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 11887 posts
    • Time Online: 550d 20h 22m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 05 September 2015 - 22:49

It's a lie, S1tool does not have implemented s1 emergency loaders for Z1S phone. Maybe phone was just discharged. Connect charger to yours and check if it will charge...


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...

#11 OFFLINE   clx

clx

    Freshly registered FAQ reader

  • User
  • 7 posts
    • Time Online: 4h 58m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Other

Posted 06 September 2015 - 08:13

Flashing all three sin_file_set didn't work, as you assumed (if one didn't work, hardly all 3 would get flashed).

 

How to test if the battery gets charged? I tried like so: while holding TestPoint ON, I connected the battery, pushed phone's CONNECT button, then connected the data cable to the PC. Theoretically, testpoint should remain ON and the PC (Device Manager, or S1tool) should see it as SOMC/SEMC flash device, right?

 

The S1Tool "readme" says so:

 

remove battery, then connect TP to GND ( any GND on board will do job ), 
insert battery, press power on button, disconnect testpoint.
 
phone will be in emergency mode, if you did thigs properly.
 
then run s1tool.exe, select msm8974 emergency mode, 

 

Well, in my case it gives the error which it gave always when I connected the phone to the PC with the battery ON (as the_laser suggested to one forum member).

 
Welcome to S1 tool.
That is small and crippled subset of SETOOL2 service tool.


SELECT FIRMWARE PACKAGES
YOU CAN SELECT SEVERAL PACKAGES WITH CTRL BUTTON
CHECKING PACKAGES ...


DETACH USB CABLE FROM PHONE
REMOVE BATTERY FROM PHONE
ATTACH TESTPOINT
PRESS "READY", THEN ATTACH USB CABLE TO PHONE


llbug: [\\?\USB#VID_0000&PID_0000#6&10ffeaf3&0&1#{a5dcbf10-6530-11d2-901f-00c04fb951ed}] open error: "The system cannot find the file specified"
Elapsed:16 secs.
 
 

 

How else to test is the battery charging from wall socket or no?

Thanks


  • 0

#12 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 11887 posts
    • Time Online: 550d 20h 22m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 07 September 2015 - 09:04

You can:

 

1. Use fully charged battery from working phone,

 

2. Charge your battery in working phone,

 

3. Charge your battery in external charger :)


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...

#13 OFFLINE   clx

clx

    Freshly registered FAQ reader

  • User
  • 7 posts
    • Time Online: 4h 58m
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Other

Posted 17 September 2015 - 16:16

Hi.

I charged the battery in an second identical phone. Now, when connected to the PC while holding down Vol - button - IT DOES show up as SEMC device.

What next? S1Tool doesn't work, same S1 loading problem error.


  • 0

#14 OFFLINE   Jurij

Jurij

    Emperror of Sony Kingdom

  • Administrator
  • 11887 posts
    • Time Online: 550d 20h 22m
  • Chat with me
  • GG:
  • Country | Страна | Kraj:
  • Operator | Oператор:
    Orange

Posted 18 September 2015 - 00:00

If you see SEMC device after you hold vol- button and connect usb cable, try to flash it using flashtool or PC Companion.


  • 0
Serwis Sony Ericsson Online | Online Sony Ericsson Service | Ремонт Sony Ericsson Oнлайн

Xperia.jpg

Więcej informacji, Cennik | More information, Price list GG: 1793684 Skype: gen.jurij

Other services: LG, HTC, Samsung, Alcatel, Blackberry, Huawei, ZTE, Motorola, Sharp unlock and more...


0 user(s) are reading this topic